Pomoc programu Kadrowiec

Kadrowiec


Praca w sieci komputerowe

Praca w sieci komputerowej.

Programy mogą pracować w sieci komputerowej współdzieląc wszystkie dane. Nie ma żadnych ograniczeń w tym zakresie i istnieją metody optymalizacji tej pracy.
1. wszystkie współdzielone dane powinny znajdować się na komputerze udostaniającym dysk w taki sposób, żeby był widoczny katalog \BR\BAZY\
2. pliki programów, czy cała zawartość \BR\PROGRAMY może i powinna znajdować się na dysku lokalnym np. C:\BR\PROGRAMY

Po uruchomieniu programy skanują dyski lokalne i zmapowane dyski udostępnione w poszukiwaniu katalogu \BR\BAZY. Jeśli chcesz ograniczyć ilość skanowanych dysków, to uruchamiaj program z parametrem /S.

Przykład:
Firma posiada siedem komputerów połączonych w sieć komputerową, ale nie posiada serwera:
SZEF, GK, KASA, KSIEGOWA1, KSIEGOWA2, SPRZEDAZ, ZAKUPY
Komputer GK (Głównej Księgowej) posiada duży dysk lokalny podzielony na partycje i w związku z tym decydujemy się na instalację danych firmy w katalogu D:\BR\BAZY\FIRMA. Ten dysk udostępniamy w sieci i mapujemy na pozostałych komputerach. Litera przydzielana mapowanemu dysku możne być dowolna jednak nie używa się liter określających domyślnie napędy dyskietek lub CD-ROM. Załóżmy, że przyjeliśmy zasadę iż mapujemy na literę F.
Wówczas otrzymamy następującą konfigurację:
GK D:\BR\BAZY\FIRMA
SZEF i pozostałe F:\BR\BAZY\FIRMA
Kolejny etap polega na optymalizacji działania oprogramowania w sieci. Jak można się domyślać działania programów jest szybsze, gdy maksymalna ilość danych jest odczytywana z dysku lokalnego np.C. Jednak stoi to w sprzeczności z pracą sieciową i dlatego pozostaje rozwiązanie polegające na przeniesieniu oprogramowania i wszystkich możliwych danych na dysk lokalny. Tak więc wystarczy, że skopiujemy cały katalog \BR\PROGRAMY z dysku Głównej Księgowej na dysk lokalny przygotowywanego komputera. Uzyskamy wtedy na komputerach C:\BR\PROGRAMY i dane na dysku F:.
Nie istnieje potrzeba kopiowania katalogu z danymi (BAZY), a wręcz nie powinno się tego robić żeby uniknąć nieporozumień w przyszłości.
Powyższa konfiguracja jest wystarczająca do rozpoczęcia pracy w sieci komputerowej.
Pozostaje jeszcze do rowiązania problem aktualizacji oprogramowania i archiwizacji danych.
Aktualizacja ( i instalacje) odbywają się domyślnie do katalogu C:\BR\PROGRAMY i w związku z tym wystaczy, że wykonamy aktualizację na jednym z komputerów, a natępnie "ręcznie" skopiujemy całą zawartość katalogu na udostępniany dysk np. F:\BR\PROGRAMY.
Zaznaczyłem "ręcznie" w cudzysłowiu ponieważ może to wykonać jakiś program lub po prostu polecenie xcopy.
...

Archiwizacja danych należy do bardzo ważnych operacji dających pewność iż po uszkodzeniu lub zniszczeniu baz nasza praca nie zostanie zmarnowana.


Klawiatura

Praca na klawiaturze

Ze względów na potrzebę przystosowania oprogramowania do masowego wprowadzania danych, zastosowano wszystkie możliwe skróty klawiszone blisko klawiatury numeryczej.

[Enter] - rozpocznij/zakończ edycję lub wybór z listy
[Esc] - zakończ lub zrezygnuj
[Ins] - nowa pozycja w tabeli
[Del] - usuń pozycję z tabeli

Pozostałe skróty do menu i poleceń "guzikowych" są ustalone w/g zasady pierwszej lub podkreślonej litery w nazwie. Wywołanie tych poleceń odbywa się za pomocą [lewy Alt]+litera.

Ponadto:
F1 - pomoc
F5 - sumuj ( jeśli jest polecenie sumowania )
F7 - szukaj
F8 - szperaj ( to rodzaj poszukiwania zagnieżdżonego )
F9 - drukuj
F10 - menu


Alerty

Jak widać są proste w obsłudze, a większość robi się sama :)

Jednak zaglądasz tutaj więc oczekujesz czegoś więcej.
Kolumna "akcja" może zawierać:
"komunikat" - wywołanie okienko informacyjne ze zdefiniowanym tekstem
"archiwum" - uruchomienie archiwizacji
"funkcja" - uruchomienie wewnętrznej funkcji programu: ImportStalych(), ImportKursow()
"program" - uruchomienie wskazanego programu zewnętrznego

Zatrzymam się na akcji "funkcja". W kolumnie "Komunikat/Nazwa" wpisz "ImportStalych()" ( bez znaków cudzysłów). Po ustawieniu parametrów czasowych program uruchomi import stałych rocznych/miesięcznych/stóp odsetkowych z Internetu. Analogicznie działa funkcja ImportKursow().


Synteza mowy

Uruchomienie syntezy mowy w programie sprowadza się wykonania kliku czynności:

1. instalacja programu "Rozmowa" z http://mowa.wp.pl
2. ustawienie opcji "Dźwięk .." na "WP" w stałych programów

Jeżeli masz syntezator mowy IVO, to wpisz do "Dźwięk" słowo "IVO".

reszta robi się sama :)

System syntezy mowy jest uruchamiany, czyli program "gada" podczas wyswietlania okienek informacyjnych i poruszania się w tabelach za pomocą klawisza kursora "w dół".


Kartoteka Osobowa

Jeżeli jakiś program posiada punkt centralny, to właśnie kartoteka jest nim dla Kadrowca.
Tutaj powinna się rozpocząć praca z programem.

Cóż można zrobić ?
Kartoteka powinna zawierać dane wszystkich osób związanych w jakimś stopniu z firmą.
Wyszczególnić tutaj trzeba przede wszystkim pracowników, zleceniobiorców, właścicieli, czyli wszystkich pracobiorców i pracodawców.

Wprowadzenie danych nowej osoby:
1. przycisk "Dodaj"
2. przycisk "Szczegóły"
3. wypełnienie wszystkich możliwych pól


Etat firmy

Często stosuje się przypisanie stanowiska do pracownika.
Tym razem zastosowano odmienną metodę polegającą na obsadzie etatowej.
Początkowo wydaje się to zbędne jednak biorąc pod uwagę wykorzystanie efektów pracy, warto poświęcić jej trochę czasu.

Etat każdej firmy składa się za działów, komórek organizacyjnych i stanowisk.


Składniki płacowe

Składnik płacowy jest to składnik sumy wszystkich elementów wpływających na wartość wynagrodzenia, podatków, wszelkich składek obliczanych dla pracownika w ramach systemu płac.
Każdy składnik posiada swoją nazwę i formułę wyliczeniową, pozostałe parametry należą do pomocniczych.

Nazwa składnika składa z ciągu liter i nie może zawierać znaków specjanych. Powinno się tak konstruować nazwę, żeby jednoznacznie charakreryzowała rodzaj i przeznaczenie składnika płacowego.


Listy płac OF - ZUS

Lista "płac" Osoby Fizycznej

Jak wiadomo program VATowiec z założenia nie może być specjalizowany dla określonego rodzaju działaności gospodarczej. Realizacja tego założenia pociąga za sobą pewne utrudnienia, ale w efekcie końcowym mamy bardzo elastyczne narzędzie, wspierające w działaności gospodarczej nie tylko Osobę Fizyczną, ale również np. Głównego Księgowego spółki akcyjnej.

W tym miejscu postaram się opisać:
Jak zbudować automatyczne księgowanie składek ZUS ?
Jak uruchamiać automat ?

Przed odpowiedzią na te pytania trzeba jednak określić miejsce działania :)
Wszystkie elementy automatu są dostępne w programie Kadrowiec.
Mamy tutaj menu:
Płace
Listy płac - wykaz list płac
Rodzaje list - definicje wzorców list
..
Składniki płacowe - definicje składników płacowych
Słowniki
Firma i właściciele - dane OF
..
Stałe
Miesięczne - tutaj wpisujemy lub importujemy z Internetu stałe ZUS
Roczne

Budowa automatu

1. definiowanie składników płacowych

- dodajemy nowy składnik
(guzik dodaj lub klawisz [Ins])
- wpisujemy nazwę "SERW"
składnik ten ma wyliczyć sumę
obowiązkowych składek społecznych
i fundusz pracy
- wpisjemy krótki opis składnika
- dodajemy kolejne składniki "SZO" i "SZZ"
- wpisujemy odpowiednie opisy
( opisy mogą być dowolne )

SZO - część składki zdrowotnej, którą możemy odjąć od podatku
SZZ - część składki zdrowotnej, którą odejmujemy od zysku 		lista_of_zus_skl.gif (10328 bytes)
w celu wyliczenia składników będziemy korzystali ze stałych
Funkcja, która odczytuje stałe nazywa się Stala(<nazwa_pola_tabeli>)

sprawdź strukturę tabeli ST_MSC w menu Zasoby->Tabele
wówczas przekonasz się, że np Stala('MUE'), to minimalna składka na ubezpieczenie emerytalne 		lista_of_zus_sklf.gif (10263 bytes)

Wyliczenie składnika SZZ, tj. części składki zdrowotnej odejmowanej od zysku jest nieco bardziej skomplikowane.
Formuła tego składnika musi zawierać różnicę składki zdrowotnej przekazanej do ZUS i części składki zdrowotnej odejmowanej od podatku. Dodatkowo zastosowaliśmy funkcję round(<liczba>,<zaokrąglenie>), żeby unikąć groszowych różnic, czyli: Stala('MPSZ')*8/100-round(Stala('MPSZ')*Stala('SZ')/100,2)

Po zdefiniowaniu składników płacowych przechodzimy do określenia wzorca ( szablonu ) listy płac.

- dodajemy nowy rodzaj listy płac ( klawisz [Ins])
- wpisujemy rodzaj "OF"
- wybieramy komórkę etatu, w której są właścicele firmy
- w szczegółach dodajemy kolejno wcześniej zdefiniowane składniki
- wybieramy kategorie Księgi Dokumentów ! 		lista_of_zus_lstdef.gif (10494 bytes)

Pojawił się nowy element określany jako Etat. Każda osoba w firmie zajmuje określone miejsce. Przydział do etatu realizujemy z poziomu Kartoteki osobowej i dalej okienka Kariera. Obsada etatowa jest niezbędna i znacznie ułatwia przyszłą pracę.

Uruchomienie automatu

Osoba Fizyczna prowadząca działalność gospodarczą opłaca składki ZUS za siebie raz w miesiącu.

Czynności do wykonania każdego miesiąca:
- import stałych ZUS z Internetu
menu Słowniki-> Stałe -> Miesięczne - prawy klawisz myszy lub F10 - import
- utworzenie nowej listy:

- dodaj listę
- wpisz za jaki okres w kolumnie RM
- wybierz rodzaj listy "OF"
- uzupełnij datę "Księga"

i już można kliknąć na "Przelicz"
po którym zostanie utworzony dokument w Księdze Dokumentów 		lista_of_zus_lst.gif (14161 bytes)

Kolumny RD, NDK, OPIS odpowiadają są przenoszone do Księgi Dokumentów, a w przypadku braku wpisu program wpisuje dane domyślne.


Absencja

Dzięki tym danym istnieje możliwość przeprowadzenia wszystkich podstawowych operacji kadrowych i płacowych. Począwszy od naliczenia należnego urlopu, poprzez naliczenie wynagrodzenia w płacach i skończywszy na świadectwie pracy.

Zapis pozycji absencji polega na określeniu dat, przyczyny i konsekwencji.
Ta ostnia czyność nie brzmi może za dobrze, ale chodzi tutaj o konsekwecje związane z różnego rodzaju stażami.

Jeżeli nie są wyliczane dni absencji, to oznacza, że program nie posiada wystarczających danych, do których należy rodzaj absencji i .. definicja dni roboczych w menu Słowniki -> Dni pracy


Dokumenty ZUS

Bloki formularzy ZUS

Skoro jesteś tutaj, to znaczy, że szukasz informacji na temat bloków ;-)
Szczegółową dokumentację formatu KEDU znajdziesz na stronie http://www.zus.pl

Tutaj jest tylko inna metoda opisu tego formatu.


Dni pracy


Dokumenty ZUS

Dokumenty ZUS - eksport do Płatnika

ZUS udostępnia program umożliwiający rozliczenie i raportowanie składek ubezpieczeniowych za płatników i pracowników.
Więcej informacji znajdziesz na stronie http://www.zus.pl

Trudność w pracy z programem Płatnik polega głównie na konieczności wprowadzania bardzo dużej ilości danych. Większość z tych danych już jest w programie kadrowo-płacowym i wystarczy je po prostu wyeksportować :-)


Formularze ZUS

to dokumenty za pomocą których odbywa się dostarczanie informacji do ZUS ;-)
Szczegółową dokumentację formatu formularzy KEDU znajdziesz na stronie http://www.zus.pl

Formularze składają się z bloków danych.


Historia pracy

Źródłem informacji do określenia stażu pracy, jubileuszy, stażu urlopowego i doświadczenia zawodowego jest historia pracy.
Wbrew temu co się ewidencjonuje w innych programach, w Kadrowcu trzeba wpisać pozycję dotyczącą aktualnego zatrudnienia (oczywiście, dla osoby zatrudnionej na umowę o pracę). Jest to zgodne z ogólną zasadą bieżącej ewidencji, stosowaną również w absencji, karierze itd.


Języki obce

Znajomość języków obcych


Kalendarz roczny


Kariera zawodowa

Podstawą do stwierdzenia, gdzie jest, co robi i za ile określona osoba, jest odpowiednio prowadzona "kariera zawodowa".
Wszystkie pozycje opisujące zdarzenia w karierze muszą posiadać swój początek, w przeciwieństwie do końca, który jeszcze nie musiał nastąpić. Załóżmy, że mamy zamiar wykonać zmianę stanowiska pracownika. Wówczas uzupełniamy datę zakończenia pracy na stanowisku dotychczasowym, dodajemy nową pozycję i wypełniamy wszytkie niezbędne dane. Nie powinno się usuwać, ani zmieniać już wprowadzonych danych.


Kody absencji


Konta bankowe

Każda osoba może posiadać kilka kont osobistych, na które może być wykonywany przelew wynagrodzenia. Jednak ze względów praktycznych uznaje się, że tylko jedno jest w danym momencie aktywne. W celu zapewnienia rzetelności ewidencji zaleca się żeby nie usuwać starych kont, a jedynie uzupełnić datę ważności.

Wykaz zawiera wszystkie osoby będące w ewidencji. Dzięki metodzie szybkiego wyszukiwania w/g nazwiska można łatwo znaleźć poszukiwaną osobę.


Kursy i szkolenia


Kasa Zapomogowo-pożyczkowa

Jak widać :)


Automatyzacja operacji KZP.

Uznaje się, że w okresie działania przynajmniej jednego automatu osoba jest członkiem KZP.


Operacje finansowe KZP.

Tutaj możesz księgować bank i kasę KZP.
Księgowania te nie mają związku z działalnością firmy, są niezależne.


Operacje KZP

Jak widać :)


Listy płac

Przed utworzeniem nowej listy płac należy zdefiniować składniki płacowe i utworzyć wzorce list.
Jeśli już masz wszystko przygotowane i wybrany wzorzec, a mimo to nie pojawiają się na liście osoby, to sprawdź w katotece osobowej "Karierę".


OSOBY.dbf

Tabela OSOBY.dbf

LP - Liczba porządkowa
 DATA - data księgowania
 RD - rodzaj dokumentu
 NDK - numer dokumentu księgowego
 OPIS_ZG - opis zdarzenia gospodarczego

KD_LP
 Liczba porządkowa jest wypełaniana automatycznie.

KD_DATA
 Data ta decyduje o prawidłowym rozliczeniu podatków.

KD_RD

KD_NDK

KD_OPIS_ZG


Rodzaje list płac


Rodzaje list płac - wybór


Rodzina


Składniki płacowe

Składniki płacowe osoby


tabela FORSA

Tabela SKLPLC.dbf - definicje składników płacowych

SKL | - nazwa składnika
RM | - od kiedy ważny
OPIS | - opis składnika
DRKNG | - tekst pierwszej linii nagłówka wydruku
DRKND | - tekst drugiej linii nagłówka wydruku
LISTA |
FRML | - formuła składnika płacowego
PASEK | - czy drukować na pasku ?


pole SKLPLC->FRML

Formuły składników płacowych

Formuła jest niczym innym jak wyrażeniem matematycznym zawierającym nazwy składników płacowych, stałe, funkcje i operatory. Składniki płacowe są reprezentowane poprzez swoje nazwy i dlatego nie mogą zawierać znaków specjanych. Stałe są zapisem liczby w składniku.

Funkcje:

DniAbs(<kod>) - dni absencji w bieżącym miesiącu dla wskzanego kodu
DniAbsr(<kod>) - dni absencji w bieżącym roku dla wskazanego kodu
DniKal(<od>,<znacznik>) - ilość dni kalendarzowych począwszy <od> dla <znacznika>
DniRob(<od>,<do>) - ilość dni roboczych w okresie <od> <do>, dla znacznika "X"
Kariera(<pole>) - wartość z tabeli Kariera i pola <pole>
Kod2Naz(<rodzaj>,<kod>) - wartość z tabeli KODYSPC-> NAZWA
KrtPr() - godziny z karty pracy
Miesiac() - numer miesiaca wyplaty
Pd(<pole>,<miesiac>) - wartość z tabeli PD i pola <pole>, dla wskazanego miesiąca i bieżącego roku listy
PlcMsc(<pole>,<miesiac>) - wartość z tabeli PLCMSC
PlcRok(<pole>,<rok>) - -"-
PlcSrd(<pole>,<miesiąc>) - średnia z wartości PLCMSC ( czyt. PlcMsc())
Pobierz(<składnik>,<miesiąc>) - odczytanie <składnik> dla wskazanego miesiąca
Podatek(<kwota>) - obliczenie podatku dla <kwota> w/g aktualnych progów podatkowych
SklPlc(<skladnik>,<pole>) - wartość z tabeli SKLPLC i pola <pole> dla wskazanego składnika
Stala(<stała>) - pobranie danych z STMSC lub STROK w/g nazwy pola <stała>
KZP() - pobranie sumarycznej kwoty operacji w kasie zapomogowo-pożyczkowej

Funkcje dodatkowe:
iif( <wyrażenie>, <wyrażenie_prawdy>, <wyrażenie_fałszu>)
val( <tekst>) -> liczba


pole SKLPLC->RM

Rok i miesiąc początku okresu ważności.

Ciągłe zmiany przepisów pociągają za sobą obowiązek dostosowania procedur wyliczania płac. Jednym z ułatwień jest możliwość wpisania początku okresu ważności, dzięki czemu możesz stosować składniki płacowe o tej samej nazwie. Jeśli zatem zainstnieje konieczność zmiany np. liczby godzin pracy dziennie, to wystarczy dodać nowy składnik płacowy o identycznej nazwie, lecz z zapisem miesiąca początku ważności.

Dzięki temu zabiegowi nie trzeba zmieniać formuł wyliczeniowych i można przeliczać dowolną listę płac, bez względu na zmianę przepisów.


pole SKLPLC->SKL

Nazwa składnika płacowego.

- powinna zawierać się w jednym wyrazie
- nie może zawierać znaków specjalnych np. +, -, *, itd.


Wykształcenie


Aktywni


Banki


tabela BANKI

tabela BANKI.dbf

NR_KIER | numer kierunkowy banku
NAZWA | nazwa banku na przelewie
NAZWA_CD | uzupełnienie nazwy banku
ADRES | ulica, plac, rondo ..
KOD | kod pocztowy lub tzw. zip
MIASTO | miejscowość siedziby banku
KRAJ | kraj siedziby
TEL1 | pełny numer telefonu
TEL2 |
FAX | pełny numer faksu


pole BANKI->ADRES

Adres banku


pole BANKI->FAX

Nr faksu do banku


pole BANKI->KOD

kod pocztowy


pole BANKI->KRAJ

kraj siedziby banku


pole BANKI->MIASTO

Miejscowość w adresie banku


pole BANKI->NAZWA

Nazwa banku


pole BANKI->NAZWA_CD

Ciąg dalszy nazwy banku


pole BANKI->NR_KIER

Numer kierunkowy banku


pole BANKI->TEL1

telefon banku


pole BANKI->TEL2

drugi telefon do banku


dostęp

Administratorem danych w tym okienku jest użytkownik o nazwie ADMIN.
Jeżeli wykaz użytkowników przekroczy jedną osobę, to program podczas uruchamiania będzie wyświetlał okienko logowania.


tabela DRK_IPS

FRM | formularz
OD_DNIA | od kiedy ważny
NAZWA | -formularza
EDYCJA | czy zgoda na edycję ?
OBLICZ | czy obliczać ?


pole DRK_IPS->EDYCJA

Czy edytować ?


pole DRK_IPS->FRM

Indetyfikator formularza


pole DRK_IPS->NAZWA

Nazwa


pole DRK_IPS->OBLICZ

oblicz


pole DRK_IPS->OD_DNIA

Od dnia


pole DRK_IPSP->FORMULA

Formuła

Dodatkowe funkcje dla programu Kadrowiec:

PobierzSklPlc(<formularz>,<nr_pola_formularza>,<czy_dla_całej_firmy>,<data_początku>, <data_końca>)
ZliczSklPlc(<formularz>,<nr_pola_formularza>,<czy_dla_całej_firmy>,<data_początku>, <data_końca>)

Pierwsza zwraca sumę wartości wszystkich składników spełniających warunki, a druga liczbę składników.
Przykłady zastosowania znajdują się w bazie firmy testowej BRTEST.


pole DRK_IPSP->POLE

pole


Druki IPS

Formularze IPS
Współpraca z programem Formularze IPS polega na eksporcie wszystkich wymaganych danych oraz uruchomieniu programu "drukform.exe"
Z założenia każdemu formularzowi odpowiada jeden plik, którego nazwa jest zgodna z symbolem formularza.

Ponieważ większość formularzy została już zdefiniowana należy zwrócić uwagę na dwie sprawy.
Pierwsza z nich, to możliwość dowolnego modyfikowania definicji w/g własnych potrzeb
i ewentualne wykonanie importu domyślnej definicji formularza.
Import ten możemy wykonać usuwając starą lub niechcianą definicję, a następnie za pomocą menu
głównego lub podręcznego wywołujemy polecenie "import". Wówczas pojawi się lista formularzy do importu.
Jeżeli nie usuniemy starej definicji, to podczas importu zostaną zaktualizowane wszystkie pola formularza występujące w definicji domyślnej.

Definicje robocze formularzy znajdują się w plikach \BR\BAZY\DRK_IPS*, a definicje domyślne w \BR\PROGRAMY\HELP\DRK_IPS*.
Istnieje zatem możliwość przekopiowania odpowiednich plików z podkatalogu HELP do podkatalogu BAZY ( usuwając jdenocześnie pliki DRK_IPS.cdx i DRK_IPSP.cdx)

Druga sprawa dotyczy definiowania formuły.
Pole formuły powinno zawierać wyrażenie wskazujące na daną do pobrania lub będącą daną dla formularza.
W formule można stosować wszystkie podstawowe funkcje języka CLIPPER i VO np.

val( <tekst> ) - zwraca liczbę
str( <liczba>, <długość>, <po kropce> ) - zwraca tekst
dtoc( <data> ) - zamienia datę na tekst
iif(<warunek>,<prawda>,<fałsz>) - zwraca odpowiednio <prawda> lub <fałsz> w zależności od spełnienia <warunek>
int(<liczba>) - zaokrągla do liczby całkowitej poprzez odcięcie
round(<liczba>,<dziesiąte>) - zaokrągla matematycznie do <dziesiąte> miejsc po przecinku ( kropce)
rtrim(<tekst>) - odcięcie spacji z prawej strony tekstu
ltrim(<tekst>) - odcięcie spacji z lewej strony tekstu
itd.

- składnia typu: DK->NAZWA

to tabela DK - kontrahenci ( bardzo dawno temu byli tylko Dostawy-Klienci )

a NAZWA, to pole w tabeli

i tak:
DK->GMINA - odczyta gminę
DK->POWIAT
DK->KRAJ
DK->WOJEWODZ - województwo
DK->TEL
wszystkie pola można sprawdzić podglądając konkretną tabelę lub plik fld.dbf zawierający wszystkie potrzebne informacje wraz z opisem

- program jest odporny na błędy w formułach


Firma i właściciele

Wszystkie pola okienka umozliwiają wprowadzenie danych niezbędnych do wykonania prawidłowych wydruków i eksportów. Wśród danych teleadresowych występują pola informacyjne typu Forma Działalności. Identycznie do ewidencji kontrahentów, należy w tym polu określić swoją firmę jako np. OF - osoba fizyczna, SJ - spólka jawna, SA - spólka akcyjna itp.

Eksport do formularzy IPS dotyczy symboli "NIP","RG","VATR","VATZ", co oznacza, że zostaną wywołane wszystkie aktualne formularze, których symbol zaczyna się znakami NIP, RG, VATR i VATZ.


Import z internetu

Wszystkie stałe miesięczne i roczne oraz stopy odsetkowe można zaimportować ze strony internetowej, której adres określa się w stałych programu. Domyślnie przyjmuje się, że tą stroną jest http://pk.inet.pl/stale.htm


tabela KURSR

Tabela KURSR.dbf

RODZ | rodzaj kursu wymiany walut
OPIS | określenie banku lub nazwa
WALTAB | waluta odniesienia, najczęściej PLN
WALUTA | waluta kursu np.USD
ZRODLO | np. nazwa banku
KK | czy kurs księgowy np. dotyczy średniego NBP
KONTO_FK | konto róznic kursowych


pole KURSR->KK

Kurs księgowy ?


pole KURSR->KONTO_FK

Konto różnic kursowych


pole KURSR->OPIS

Opis kursu


pole KURSR->RODZ

Rodzaj kursu walut


pole KURSR->WALTAB

Waluta tabeli


pole KURSR->WALUTA

Waluta kursu


pole KURSR->ZRODLO

Źródło kursu


tabela KURSW

Tabela KURSW.dbf

DATA | data kursu
DATA_WAZ | ważność
KURS | wartość kursu
CECHA | potęga 10 np. 2 dla możnika 100
UWAGI | np. nr tabeli NBP


pole KURSW->CECHA

cecha kursu walut, potęga 10 mnożnika


pole KURSW->DATA

Data kursu


pole KURSW->DATA_WAZ

Data ważności


pole KURSW->KURS

Kurs


pole KURSW->UWAGI

Uwagi


Kursy walut

Kursy walut obcych
powinny być ewidencjonowane w przypadku prowadzenia transakcji w walucie obcej.

Ewidencja ta nie powinna sprawiać trudności i zwrócę uwagę na sprawę importu kursów z internetu.
Przed uruchomieniem importu należy wpisać poprawny adres do pliku z tabelą kursów walut.
Kursy średnie NBP są publikowane pod adresem http://www.nbp.pl/Kursy/KursyA.html
a kursy kupna-sprzedaży http://www.nbp.pl/Kursy/KursyC.html
Proszę zwrócić uwagę na wielkość liter występujących w adresie ponieważ większość serwerów je rozróżnia.

Istnieje również możliwość wpisania adresu nie wskazującego na plik z tabelą kursów np.
kursy celne znajdujące się pod adresem
http://www.mf.gov.pl/sluzba_celna/kursy_walut/index.php?dzial=537&id1=32214&id2=32215
( kiedyś http://www.guc.gov.pl/i.php?i=kursywalut )

Wszelkie uwagi proszę wysyłać na adres e-mail p@inet.pl


pracusie


Raporty definiowane

są sposobem na szybkie uzyskanie wybranych informacji z bazy danych programu.
Raporty podzielono na tematy, którym odpowiada określony zestaw tabel bazy danych. Przechodząc do definiowania nowego raportu należy wybrać interesujący temat, a następnie, typowo, dodać nową pozycję i wpisać nazwę raportu. Nazwa pojawi się na wydruku obok tematu. Kolejnym etapem definiowania raportu jest określenie kolumn na podstawie proponowanego zestawu znajdującego się o okienku listy. Kliknięcie na odpowiedni guzik ">" lub też "<" powoduje włącznie pola do raportu lub też wyłączenie. Tabela wykazu kolumn raportu umożliwia zmianę treści nagłówka, blokadę wydruku ( wstawiona kolumna może być użyta wyłącznie do filtra), określenie sortowania i zdefiniowanie filtrowania danych.

Filtrowanie.
Zagadnienie wyboru danych do raportu należy do najważniejszych i skuteczne ograniczanie decyduje o mozliwości wykorzystania raportu. Wprowadzono następujące operatory:
" " - brak operatora - filtr jest wyłączony

operator | pole tekstowe | pole numeryczne | pole daty
<< | dana z pola zawiera się w wartości | dana mniejsza ponad 1000 razy | data z pola o przynajmniej rok wcześniejsza
< | dana jest mniejsza w sensie alfabetu | dana mniejsza | data z pola wcześniejsza
= | teksty są sobie równe | obie równe | równe daty
# | teksty różne | obie różne | różne daty
~ | teksty podobne (zawierają się w sobie) | wartości przybliżone do 10% | przybliżone daty
> | dane większa w sensie alfabetu | dana większa | data pola późniejsza
>> | wartość zawiera się w tekście pola | dana większa ponad 1000 razy | data pola późniejsza ponad rok

Budowanie filtrów złożonych polega na składniu filtru z warunków dla wielu wybranych pól. Musimy wiedzieć, że domyślnie zakłada się spełnienie wszystkich warunków, czyli zastosowano operator logiczy "i". Jeżeli jednak istnieje potrzeba zdefiniowania filtru z zastosowaniem operator "lub", to wystarczy skorzystać z pola NF ( negacja filtru ) w nagłówku definicji raportu. Odznaczenie tego pola spowoduje wybranie danych do raportu, gdy zdefiniowany filtr nie jest spełniony.
Dalej należy skorzystać ze znanej zależności:
!( a i b) = ( !a lub !b), gdzie znakiem "!" oznaczono negację wyrażenia.

Przykładowo:
Zadanie polega na wygenerowaniu raportu sprzedaży dla dwóch klientów o nazwach skóconych: KLIENT1 i KLIENT2.
Do raportu wstawiamy dwie kolumny NAZWA_SKR i jedną z nich zaznaczamy, że ma się nie drukować. Po zdefiniowaniu pozostałych kolumn raportu pozostaje konieczność wstawienia odpowiednich warunków do filtru. Do pól zatytuowanych "Wartość" wpisujemy odpowiednio wymagane nazwy klientów oraz wybieramy operatory "#" ( różny). Następnie musimy zaznaczyć pole NF w nagłówku definicji raportu. Jak widać wygląda to wszystko nieco skomplikowanie, ale to tylko pozory.

W programie księgowym powinna być możliwość wykonania raportu zawierającego sumy kwot lub zliczenie liczby pozycji. Raporty Definiowane mają taką możliwość po zaznaczeniu opcji "ZLICZ" w nagłówku raportu. Efektem raportu zliczonego jest tabela zawierająca kolumny określone jako nagłówki wieszy ( nie polegają sumowaniu, ani zliczeniu ), które grupują dane i kolumny zawierające sumy pól numerycznych oraz zliczone pozostałe pola. Sprawdź działanie opcji zliczania drukując raport w obu jej stanach. Wówczas wszystko stanie się jasne ;)

Szczególne przypadki zastosowania raportów definiowanych wymagają zastosowania pól wyliczeniowych. Istnieje możliwość wykorzystania w tym celu kolumny "Formuła" specyfikacji raportu. W polu tym trzeba zapisać taką formułę, która umożliwi programowi pobranie i wyliczenie wymaganej wartości. Np. zapisując tabela1->pole1-tabela1->pole2 uzyskamy pole wyliczeniowe równe różnicy pól pole1 i pole2 tabeli1.
Wartość wyliczeniowa może być porównywana z wartością wpisaną zgodnie z zadanym operatorem.


Raporty definiowane - definiowanie

Definiwanie "Raportów definiowanych"

Jeżeli nie musisz tutaj zaglądać, to raczej nie zaglądaj :-)
Wszystkie dane zawarte w tabeli są bardzo ważne dla "Raportów definiowanych".
To tutaj można określić wszystkie tematy, a co za tym idzie tabele i sposób ich połączenia.

Pewien zestaw raportów ustalono jako domyślny i podlegający importowi. Jeśli zatem w wyniku zmian definicji program nie będzie wykonywał zamierzonych raportów, to można wykonać import domyślnych ustawień.

Czytasz dalej więc chcesz się dowieć co i jak można zdefiniować.
Na początek trzeba określić źródło danych do raportu definiowanego. Przykładowo, chcemy wydrukować adresy kilku firm. Określamy zatem treść tematu np. "Dane kliku firm". Następnie zaglądamy do menu System -> Zasoby -> Table i szukamy tabeli zawierającej dane firm. Nazwa tabeli ( tutaj DK ) musi być wpisana do kolumny "Tab". I to koniec definicji. Przejdź do Raportów Definiowanych i wybierz swój temat raportu ( swoją definicję ).


tabela ST_ODS

Tabela ST_ODS.dbf - stopy odsetkowe

R | rodzaj odsetek
DZN_START | od kiedy ważne
DZN_STOP | do kiedy ważne
NA_DNI | skala odsetek (dzień lub 365=rok )
STAWKA | procent odsetek
PDST_DZN | informacja dodatkowa, podstawa prawna
PDST_NR |


pole ST_ODS->DZN_START

Data początku ważności


pole ST_ODS->DZN_STOP

Data ważności


pole ST_ODS->NA_DNI

Okres przeliczeniowy


pole ST_ODS->PDST_DZN

Podstawa prawna


pole ST_ODS->PDST_NR

Podstawa prawna: nr dokumentu


pole ST_ODS->R

Rodzja odsetek


pole ST_ODS->STAWKA

Stawka odsetek


Stałe miesięczne

Rozliczenie z Urzędami wymaga zastosowania wielu "stałych" danych.
W tej tabelce należy wpisywać dane zmieniające się przynajmniej w cyklu miesięcznym.
Stałe mogą być odczytywane w formułach wyliczeniowych z zastosowaniem funkcji STMSC(<pole>), gdzie pole określa pole tabeli STMSC.

Podobnie jak stałe roczne i stopy odsetkowe można wykonać import danych z internetu wywołując polecenie "import danych"


Stałe programów

Często zmieniające się przepisy oraz różne upodobania użytkowników wymusiły powstanie okienka zawierającego stałe dla wszystkich programów pakietu. Okienko nie wygląda standardowo, tj. tak jak się przyzwyczailiśmy w innych programach z dwóch podstawowych względów. Po pierwsze stałe dotyczą również wersji dla DOS co wymusza nieco inne podejście, a po drugie, taka kontrukcja umożliwia bardzo szybkie odczytywanie z zapisywanie stałych. Program nie musi stosować specjanych procedur odczytu, czy też blokowania stałych. Nie istnieje potrzeba wychodzenia z programu po zmianie danych, po prostu wystarczy zmienić i dalej pracować.


Stałe roczne

Rozliczenie z Urzędami wymaga zastosowania wielu "stałych" danych.
W tej tabelce należy wpisywać dane zmieniające się przynajmniej w cyklu rocznym.
Stałe mogą być odczytywane w formułach wyliczeniowych z zastosowaniem funkcji STROK(<pole>), gdzie pole określa pole tabeli STROK.

Podobnie jak stałe miesięczne i stopy odsetkowe można wykonać import danych z internetu wywołując polecenie "import danych"


tabela STMSC

Tabela STMSC.dbf - stałe miesięczne

RM | miesiąc obowiązywania
MPS | minimalna podstawa składek
MUE | minimalna składka na ubezpieczenie emerytalne
MUR | minimalna składka na ubezpieczenie rentowe
MUC | minimalna składka na ubezpieczenie chorobowe
MUW | minimalna składka na ubezpieczenie wypadkowe
MUZ | minimalna składka na ubezpieczenie zdrowotne
MFP | minimum na Fundusz Pracy
PZU | składka PZU


pole STMSC->MFP

Minimalna składka na Fundusz Pracy


pole STMSC->MPS

Minimalna podstawa składek


pole STMSC->MUC

Minimalna składka na ubezpieczenie chorobowe


pole STMSC->MUE

Minimalna składka na ubezpieczenie emerytalne


pole STMSC->MUR

Minimalna składka na ubezpieczenie rentowe


pole STMSC->MUW

Minimalna składka na ubezpieczenie wypadkowe


pole STMSC->MUZ

Minimalna składka na ubezpieczenie zdrowotne


pole STMSC->PZU

Składka na PZU


pole STMSC->RM

Miesiąc stałych


pole STMSC->SKM_MAX

Stawka za kilometr dla silników powyżej 1,6 litra pojemności


pole STMSC->SKM_MIN

Stawka za kilometr dla silników do 1,6 litra pojemności


Stopy odsetkowe

Poprawne obliczenie odsetek bez wpisania aktualnych stóp jest niemożliwe i dlatego zaleca się wykonywanie ciągłej aktualizacji tej tabli.

Podobnie jak stałe miesięczne i roczne, można wykonać import danych z internetu wywołując polecenie "import danych"


tabela STROK

Tabela STROK.dbf - stałe roczne

SPP | stawka podatku dochodowego od osób prawnych
KUZ | koszty uzyskania - zwykłe
KUP | koszty uzyskania - podwyższone
FG | Fundusz Gwarantowanych Świadczeń Pracowniczych
FEP | Fundusz Emerytalny - pracownik
FEZ | Fundusz Emerytalny - zakład
FRP | Fundusz Rentowy - pracownik
FRZ | Fundusz Rentowy - zakład
FP | Fundusz Pracy
FW | Fundusz Wypadkowy
SC | Składka Chorobowa
SZ | Składka Zdrowotna
KW | Kwota Wolna
ZUSOGR | Ograniczenie składek ZUS


pole STROK->FEP

Fundusz Emerytalny - pracownik


pole STROK->FEZ

Fundusz Emerytalny - zakład


pole STROK->FG

Fundusz Gwarantowanych Świadczeń Pracowniczych


pole STROK->FP

Fundusz Pracy


pole STROK->FRP

Fundusz Rentowy - pracownik


pole STROK->FRZ

Fundusz Rentowy - zakład


pole STROK->FW

Fundusz Wypadkowy


pole STROK->KUP

Koszty uzyskania - podwyższone


pole STROK->KUZ

Koszty uzyskania - zwykłe


pole STROK->KW

Kwota wolna


pole STROK->SC

Składka Chorobowa


pole STROK->SPP

Stawka podatku dochodowego od osób prawnych


pole STROK->SZ

Składka zdrowotna


pole STROK->ZUSOGR

Ograniczenie ZUS


tabela waluta

Tabela WALUTA.dbf

WALUTA | kod ANSI waluty
KOD | kod numeryczny
CECHA | potęga mnożnika
NAZWA | nazwa waluty
KRAJ | kraj obowiązywania
SW | symbol
DROBNE | nazwa drobnych
SWD | symbol drobnych


pole WALUTA->CECHA

Cecha mnożnika


pole WALUTA->DROBNE

Nazwa drobnych


pole WALUTA->KOD

Cyfrowy kod waluty


pole WALUTA->KRAJ

Kraj waluty


pole WALUTA->NAZWA

Nazwa waluty


pole WALUTA->SW

Symbol waluty


pole WALUTA->SWD

Symbol drobnych waluty


pole WALUTA->WALUTA

Symbol waluty w/g ANSI


waluty

Rodzaje walut


Wieloodziałowość

Oprogramowanie posiada mozliwość pracy wieloodziałowej.
Pracę tą można zorganizować w dwóch systemach komunikacyjnych:
- niezależnym
- zależnym

System komunikacyjny niezależny polega na przesyłaniu plików wyeksportowanych danych i importowaniu ich u adresata. Niezależność wynika z faktu, iż nie są przenoszone identyfikatory, unikatowe numery dokumentów, kontrahentów, towarów itd. Każdy z oddziałów ma swoją własną i niezależną bazę danych.

System komunikacyjny zależny polega na wysyłaniu i odbieraniu przesyłki, która zawiera pełne dane z bazy oddziału tj. włącznie z unikatowymi numerami rekordów jak np. identyfikator dokumentu, kontrahenta, towaru itd.

Oba systemy mają swoje właściwości.


Parametry wydruku

Parametry wydruków

Wszystkie programy pakietu zapamiętują ustawienia wydruków dla każdego raportu, komputera i użytkownika. Wśród tych parametów jest drukarka, układ strony i liczba kopii. Zdolność zapamiętywania parametrów jest szczególnie ważna w pracy sieciowej oraz przy wykorzystaniu komputerów przenośnych.


Zasoby - indeksy

Wykaz zawiera wszystkie indeksy tabel bazy danych.


Zasoby - pola

Wykaz zawiera wszystkie pola ( kolumny ) tabeli bazy danych.


Zasoby - tabele

Baza danych oprogramowania posiada strukturę przypominającą drzewo.
Pierwszym poziomem tego drzewa jest fizyczna lokalizacja plików zawierających tabele i indeksy. Jak już zapewne wiesz wszystkie dane są zapisane w \BR\BAZY i dalej odpowiednio w podkatalogach odpowiadających ewidencjonowanym firmom.

W tym wykazie umieszczono wszystkie tabele bazy danych, a ich lokalizację określono w polu "Sc."
Każda tabela składa się z pól i rekordów, pole odpowiada kolumnie tabeli, a rekord wierszowi.
Wszystkie pola stanowią strukturę tabeli, która nie jest zmieniana podczas normalnej pracy, lecz może być zmieniana podczas wykonywania aktualizacji oprogramowania. Dane zapisane w rekordach ( wierszach ) są zmieniane w czasie pracy z programem.

Wykaz zawiera wszystkie tabele wraz z opisem i pewnymi parametrami. Dla Ciebie i Urzędów kontrolnych najistotniejszy jest opis.